ldap password with an @ --> cmd test and "base DN Fixe" fail to connect

  • hello every body ,

    i wana test Veyon and buil a VM poc.

    • when i try to connect to ldap server via the gui -> connection succed.

    • when i try to configure base DN the test fail :

    Sans titre.png

    I follow the Veyon documentation and try on terminal (CMD windows 7 for this test ) with this patern :
    veyon-ctl ldap autoconfigurebasedn ldap://Administrator:MYPASSWORD@
    "Les arguments donnÚs ne sont pas valide"

    I think the PB is my admin passwordcontain an @ this caracter use to delimit ... so i 've tried to echap it, adding quotes ... but i always get the same reply "bad arguments"

    Did somedody know how to echap the @ ?

    thanks for your help

  • Hi,
    I just updated the docs at https://docs.veyon.io/en/latest/admin/ldap.html#command-line-interface to include a hint on how to encode special characters using percent-encoding. In your case you can specify %40 for @.
    Best regards

  • @tobydox Thanks for your help Tobydox, i have tried in cmd under windows and i always get an error. If i try with the graphic interface authentification "@" in my password this work perfectly.