Bionic : Issue with demo mode



  • Hi,

    My masters and clients are using ubuntu 18.04, Veyon 4.2.5 (but had the same issue with 4.1.91).

    When I try to launch demo from server to clients, connexion is pending (black screen and "Establishing connexion to..." message), but never starts.

    It seems to be new in bionic, since it worked for me with ubuntu Xenial and Veyon 4.1.91 (and with bionic, even 4.1.91 doesn't work).
    Everything else works fine.

    Am I the only one to meet this issue ?

    I took a look at the doc :
    https://docs.veyon.io/en/latest/admin/troubleshooting.html#in-demo-mode-only-a-black-screen-or-window-is-displayed-on-client-computers
    And I'm surprised I can see no "network settings" in veyon configurator's Service page.

    Veyon is configured with configuration files, which are exactly the same I used in ubuntu 16.04

    If someone can help...

    Thanks



  • First of all: in Veyon 4.2.0 and newer some settings are only visible when switching to the advanced view through the menu.

    Regarding your issue: it's an interesting observation! There should be no difference between 16.04 and 18.04 so whatever causes the problem is probably related to the different versions of Qt5. Can you spot any differences in the log files on the master computer when starting the demo mode?



  • Hi,

    Not easy for me to test differences between 16.04 and 18.04, since I don't have no 16.04 PCs (all my machines have been migrated).
    I'll try as soon as possible to get to 16.04 vm to test.
    In 18.04, on master, all veyon log files are empty, except /var/log/VeyonService.log. In this file, I only find start and stop logs at every logging/unlogging from users.



  • Hi,

    I finaly had time to make tests from scratch (no configuration), and I found what was wrong :
    On my teacher's PC, I didn't automatize version's server launch at session's start.
    I didn't have to do that with former install on 16.04 and 4.0.4.
    It was not a conf issue, then.

    Thanks for your help and your great job.

    E.T.


Log in to reply