Ignore some LDAP rooms



  • I use a Novell eDirectory LDAP to query room OUs for related rooms. This works well, but there is still a problem, which I do not get solved.

    We have a parent ou "ou = Arbeitsstationen" in which the ou "ou = room001" etc. are located.
    Veyon Master 4.1.7 will now switch to the room "Arbeitsstationen" on one start, and the room "Room001" on the other start.
    Is there a way for the LDAP-based query of the associated rooms to exclude a room ("Arbeitsstationen") or to use only the highest room in the hierarchy?

    I found a dirty workaround. Beginning with Veyon Master v4.1.9 it showes room "Arbeitsstationen" every time. It seems it uses always alphabetical order. So it is a workaround to rename the ou ... 🙂

    Thanks
    Sven



  • Hello,

    have you enabled or disabled recursive LDAP queries? Changing the setting also affects how rooms in an OU are queried.



  • Hello and thanks

    Recursive search is active, but it is also needed because of the nesting of user groups and room groups.

    This is related to bugtracker https://github.com/veyon/veyon/issues/465 .
    The renaming is a working workaround for me. Pay attention to the alphabetical order of nested items in the LDAP tree.

    -workstations
    -- Workdepartment1
    ---- Room01
    ---- Room02
    -- Workdepartment2
    ---- Room03
    ---- Room04

    That's how it works for at the moment. 🙂


Log in to reply