Service Start/Stop Buttons Grayed Out(Linuxmint)



  • What should I do to start the service? Installed the app through package manager and via .deb but everytime I having the same problem. Tried many linux distros, followed many step-by-step solutions but couldnt start master or client.



  • Are you using one of the Veyon 4.1 pre-releases? I'm asking because in Veyon 4.0 there's no proper system service support on Linux yet.



  • Solved that problem by installing 4.1.4 but this time I have another problem with the service. The "veyon-service" seems running properly on every pc including the master pc but clients' previews goes red randomly on master and not responding until I use "sudo service veyon-service restart" command via SSH. Sometimes master pc needs that command or need stop and start the service on Veyon-Configurator to use Veyon Master.
    PS: Tray icons dissappear when this problem occurs but service still seems fine.



  • The service "only" launches server instances inside user sessions so if the tray icon disappears certainly the server crashed. This is quite hard to debug. Which distro/version and desktop environment are you using? Can you try to set the log level to debug on clients and examine the server and service log files?



  • Using Linuxmint 19 Tara and XFCE desktop. I don't know what to examine but I uploaded the log files in my google drive, here is the link to it.
    veyon_logs.zip


Log in to reply