Veyon keys not setup properly Ubuntu 18.04

  • I had been using Veyon for several years with no problem. This year I have tried everything to get Veyon to work in my classroom to no avail. I am using authenication keys but can't get it to work.

    My clients are running Ubuntu 18.04 and have the most recent version of Veyon installed.

    My master is running Windows 10 and have the same version of Veyon installed.

    I set up my keys on master and import them on client. When I click "test" to see if they are set up properly, it returns the message "keys are not setup properly on this computer".

    I notice that the public key id on the client is different than on the master.

    Any help would be appreciated. Never had a problem getting this to work in the past.


  • Hi,
    the message "keys are not set up properly" only appears if you did not install the private key (which is not necessary for client computers) so don't worry about that. The key pair ID can be different across platforms due to differences in the SSL implementations (we're working on a fix for this). I guess you're hitting one of the most typical problems in IT: permissions. Can you verify that the public key file on the client computers is readable by everyone? Do the log files (/tmp/VeyonServer.log) indicate any authentication problems? Have you set authentication type to "Key file authentication" on clients?

  • @tobydox I have the public key on the client set to read only access for everyone. Still no joy.

  • @tobydox looking in the VeyonMaster.log is see this warning a couple of time:

    [WARN] QProcess: Destroyed while process ("ping") is still running.

  • @tobydox in the Veyon.Configurator.log file I see this error:

    [ERR] CryptoCore: failed to decrypt password!

  • @tobydox on the client in the VeyonService.log I see this message:

    [ERR] LinuxServiceCore: Can't start Veyon Server in Wayland sessions as this is not yet supported. Please switch to X11-based sessions!

  • @hammergil Veyon currently only suports X11-based sessions so if you have the chance to change the session type, please switch to X11-based Gnome, KDE or whatever desktop environment you're using.

  • @tobydox The session type for Ubuntu 18.04 is X11.

    typing "echo $XDG_SESSION_TYPE" in the terminal returns "X11"