Can connect to client, see thumbnail on main panel but remote view/control don't connect


  • I am using Veyon Master on Linux Mint 19.3 as master accessing a Windows 10 client computer. Both are running Veyon 4.5.2. I am configured to use Key File Authentication. When I start Veyon Master on the Linux machine I see a pop-up notification on the client Windows screen within about 10 seconds that says I am accessing the machine and the computer icon in the Veyon Master shows a thumbnail of the client Windows Screen. When I try Remote View or Remote Control, however, the view window says Connecting... but it never does. The VeyonMaster.log has two warnings when I start it:

    2021-02-07T06:08:02.532: [WARN] inotify_add_watch("%APPDATA%/Screenshots") failed: "No such file or directory"
    2021-02-07T06:08:27.981: [WARN] QTimeLine::setDuration: cannot set duration <= 0
    

    Occasionally, Remote Control will work, and when it works it works fine, but most of the time it doesn't. I stopped and restarted the service on the client and within about 10 seconds a notification pops up again on the client saying I am accessing the computer followed in about 30 seconds by a notification saying there was an authentication error followed in another 10 seconds by the notification saying I am accessing the computer and then Veyon Master connects successfully. There are more entries in the VeyonMaster.log:

    2021-02-07T06:54:10.507: [WARN] ---
    2021-02-07T06:54:10.508: [WARN] Last message repeated 2 times
    2021-02-07T06:54:10.508: [WARN] ---
    2021-02-07T06:54:10.508: [WARN] VariantArrayMessage: could not read message size!
    2021-02-07T06:54:10.509: [WARN] VariantStream: none or invalid data read
    2021-02-07T06:54:10.509: [WARN] VariantArrayMessage: could not read message size!
    2021-02-07T06:54:10.509: [WARN] VariantStream: none or invalid data read
    

    Obviously, it's very inconvenient if I need to restart the service on the client every time before I use Veyon Master. Any insights are greatly appreciated.


  • @aok8ykfgeuoi same to me, i got this problem with 25pcs,

    Everything normal so the demo is fine.
    But remoting student pc , sometimes it goes fast , normal but sometime it take 1-2min and sometime it just connecting ....

    Still didnt find the solution right now.


  • The VariantArrayMessage messages are interesting. They seem to indicate some kind of protocol incompatibility issue between master and client computers. Did you compile Veyon on your own on Linux Mint? If so, which version of Qt 5 is installed?

    Regarding the screenshot warning: thanks for pointing that out! I just fixed the issue which will also be part of the upcoming 4.5.3 release.