• Hello.
    There was a problem with dependencies when installing Veyon in KDE Neon 5.20.5 ( 20.04 LTS).

    cat veyon-ubuntu-stable-focal.list
    deb http://ppa.launchpad.net/veyon/stable/ubuntu focal main
    
    apt-get install veyon
    Reading package lists ... Done
    Building a dependency tree
    Reading status information ... Done
    Starting pkgProblemResolver with broken count: 1
    Starting 2 pkgProblemResolver with broken count: 1
    Investigating (0) veyon: amd64 <none -> 4.5.2-2 ~ focal @un puN Ib>
    Broken veyon: amd64 Depends on qtbase-abi-5-12-8: amd64 <none @un H>
      Considering libqt5core5a: amd64 3305 as a solution to veyon: amd64 9999
    Done
    Some packages cannot be installed. Perhaps what you ask for is
    is not feasible, or you are using an unstable version of the distribution where
    the packages you requested have not yet been created or have been removed from Incoming.
    The following information may help you:
    
    The following packages have unmet dependencies:
     veyon: Depends: qtbase-abi-5-12-8
    E: Unable to fix errors: you have broken packages fixed.
    

    Please tell me how to fix this problem?


  • @dmitriy said in INSTALLING IN KDE NEON 5.20.5:

    qtbase-abi-5-12-8

    Neon Qt version not compatible.


  • Exactly, it looks like KDE NEON is not fully binary compatible with Ubuntu 20.04. I suggest to build the Veyon package on your own as described here: https://github.com/veyon/veyon/blob/master/README.md#veyon-on-linux