Veyon master Windows doesn't see rdp connections

  • Hi, I'm using veyon on some windows rooms (windows 10, Veyon 4.3.4).
    Everythings works well when users are connected to "physical" PCs, but veyon master doesn't detect rdp connections to hosts.
    I can see the PCs in master's interface, connect to it, but when a user is RDP connected to one of them, I can't see his session. If I try a remote control, I got the connection panel, as if nobody were there.
    I activated the multisession option on clients ans master, no more result.

    This issue doesn't happen with my linux rooms

    Did I miss something ?

  • Hi,

    that's exactly my problem , too. I have problems to view logged in users in RDP-Sessions on win 2019 and win2012R2 Servers. I'm using default config. Veyon Master is showing computernames and the Name of logged in user at console, but not of the RDP-Users, not on 2012 R2, 2019 and not on Win10. On the Clients / Terminalservers the VeyonClient shows the ports e.g. 11102 but only the VeyonClient-session (11100) of the console shoes "connected to ....". In the other RDP-Sessions the VeyonClient shows a different port (e.g. 11102) but not wether it is connected or not. On the Master-PC a telnet to the specific port of the clients works.
    All antivirus and firewall settings are deactivated for testing but no positive result.

    (Using Veyon 4.3.5)

  • where is this multisession option? can't find it

    nevermind, found you have to enable advanced settings, then it's inside "service"

    multimode doesn't seem to be working for me either on windows 10 1607

    Hi @hoomank
    there's a test build available at which has improved multi session support which should work out-of-the-box

    but I'm using veyon 4.3.5 and still have the issue

    As a workaround you can try to disable the Veyon Service at all and launch Veyon Server instances manually inside the sessions. Within each session the environment variable has to be set to an distinct value so that the corresponding Veyon Server instance listens on different ports

    this works for me, since I only have 1 rdp session on each computer, but maybe some clarification about the environment variable would be nice

  • Hi,

    I didn't have much time to solve this issue, last months, but I'm back on it now...
    I tried to launch Veyon server instance manually inside the session, but it had no effect at all.
    Maybe I'm not doing what I should, though.

    First, my PCs are Win10 (no server version).
    I tried some commands like :
    C:\Program Files\Veyon\veyon-service.exe restart
    (and the same with veyon-server, veyon-worker)

    But veyon master still doesn't see the user's session.
    @myself : Could you give us more precisions about the commands you used to do that ?

    If it works, I'll just have to create an at-session-start task to enable it, and I think it could make it


  • In fact, it seems commands like C:\Program Files\Veyon\veyon-service.exe restart have absolutly no effect.
    I tried with service stop (and server too) on the client, and it changes anything in veyon master : the client is still here and responding.

    It can explain why my tests don't work...

    What am I missing ?...