Veyon 4.5.4 VNC serveur Crash on demo mode

  • @drewloker said in Veyon 4.5.4 VNC serveur Crash on demo mode:

    Did you downgrade the entire lab to 4.4.2?
    I still can not get Demo to work on anything from 4.4.2 through 4.5.4. The last time Demo worked for me was on 4.3.5. Since upgrading in September 2020, to 4.4.2, Demo has not worked.
    Do I need to down grade the clients if I take the MASTER back to 4.3.5?

    I only did the test in 442 on 1 PC with the master and 1 PC with the client. and the demo mode works with the settings I made

  • @drewloker Have you tried disabling the mentioned option ("Enforce selected mode for client computers")? Currently this option causes problems with the demo mode in 4.5.x which will be fixed in the next release. However when disabling it, demo should work normally.

  • BTW Veyon 4.5.5 fixes demo mode with the "Enforce selected mode for client computers" option enabled.

  • @tobydox
    Hello thank you for coming back ... I will test this soon

  • Hello again
    I have just made a trial installation of version on a computer which previously had version
    Scenario I uninstall the previous version, reboot the machine installation of version .. installation OK, but when I run Veyon-configurator => crash with error message 87
    I downloaded the installation sources for version twice to be sure, always the error message.
    if I uninstall version and reinstall version .. no problem ...

    I tried to install version over version without uninstalling => error 87

    Obviously when switching from version to there is something in the configuration file that does not work .. what is weird is that obviously the configuration remains on the PC because when I reinstall the version my LDAP and co configuration is still present even though I uninstalled it before. and delete the installation folder c : \ programfiles \ veyon
    I looked everywhere in Appdata of the user folder, that of the public user but also in ProgramData ..

    an idea ??

    Edit: After uninstalling I deleted the registry key
    Computer \ HKEY_LOCAL_MACHINE \ SOFTWARE \ Veyon because it remains => reboot => install always the same error

  • If I install on a new machine (virtual machine) where a previous version of veyon was not installed => OK no worries ....

  • I also did manipulation on a machine with Veyon 4.3.5 uninstallation then update to version 4.5.5 .. everything is OK ... I will do other tests on the first PC

  • OK, thank you for the feedback!

  • Good evening tobydox
    I keep trying ... even when cleaning the registry database and Appdata folder there is nothing to do .. I can install version,, without having error message and everything is working fine.
    But if I install or I get the 87 load library failed error message.
    from 4.5.6 or if I reinstall one of the 3 previous versions everything is OK even without restarting the computer ...

    Do you have an idea for me ?? I would like not to need to format the computer because I have a lot of big software for which it takes a few hours of installation ...

  • Hello Tobydox
    I now know the problem of error 87 ... but I don't know how to solve it yet ...
    the error occurs if I am connected in RDP on the machine on which I am installing Veyon. if I am physically connected to the machine no more error 87 problem. From the information I could read, this is related to graphics driver problem ...
    But you have necessarily done something about the graphics settings since until version this does not pose a problem in RDP.