Veyon 4.5.4 VNC serveur Crash on demo mode


  • @fred Thank you for the logs (only the master/server logs are relevant at the moment). They clearly indicate that the demo server worker is crashing for some reason. I created a test build and uploaded it to https://github.com/veyon/veyon/releases/download/v4.5.4/veyon-4.5.4.3-win64-setup.exe - it includes many more debug messages as well as one minor change. Can you please upgrade the master computer, clear the log files and start a demo (no matter whether window or fullscreen) again and attach the server log file to your response (better than to include it to keep the thread clear)? That would help me a lot! Thank you in advance for your cooperation!


  • @tobydox
    Hello I am trying to do some tests during the day. on the other hand, I can only attach images to the message, not log files ...
    I have a message saying I don't have enough privileges ...
    Fred


  • @fred No problem, than either paste it at a website like pastebin.com or keep pasting here 😉


  • @fred in case you did not start testing yet, you can try the https://github.com/veyon/veyon/releases/download/v4.5.4/veyon-4.5.4.4-win64-setup.exe release with even more debug logs.


  • @tobydox

    Hello, here is the master version 4.5.4.4 log

    https://www.cjoint.com/c/KDbm4nhPPWH
    Fred


  • @fred Thank you very much! Did you start the demo mode just once? Or did you repeatedly start/stop it or did anything else after starting? How did you start it? Using the global toolbar or the context menu? How many clients do you have activated in the locations and computer tab? I'm just asking because I see many intermittent "stop demo" requests which repeatedly stop the server and start it later again.


  • @tobydox

    I had done 3 tests because on the master station I have a dual display (2 monitors)
    a test with monitor 1
    a monitor test 2
    a test by having disconnected monitor 2 and keep only one with the same reference as on the client pc

    always with a single client pc in 4.5.4

    new test:
    New log file.
    https://www.cjoint.com/c/KDbodNHpTgH
    1 single client with demo mode 1 single monitor on the master
    Click on the general mode demo menu in the window this time.
    only one demo requested ... but on the client pc several disconnections
    Capture.PNG


  • @fred Interesting! Obviously the demo server is not crashing (which is good!) but stopped by the Master due to a bug. One guess: do you have the "Enforce selected mode for client computers" option (https://docs.veyon.io/en/latest/admin/reference.html#behaviour) enabled? If so, can you try to disable it for testing?


  • Good evening
    indeed the box was checked.
    Capture.PNG
    I just did a remote test. by unchecking the box. Attached is the log of this test ...
    https://www.cjoint.com/c/KDbtVXafWck
    It seems that the demo mode is functional in this case. But without being in the room and seeing the pc directly.

    Knowing that I am in France and that the government is imposing the closure of schools .. it will be difficult to get correct tests while being in the classroom in the coming weeks ..
    From a distance I have the impression that the demo mode is not fluid .. too much latency between modification on the master station and the client .. but without being 100% sure
    Fred


  • Hello I have checked today on version 4.4.2 the box
    "Enforce selected mode for client computers"
    is activated ... and the demo mode works correctly on this version
    Fred


  • @fred Did you downgrade the entire lab to 4.4.2?

    I still can not get Demo to work on anything from 4.4.2 through 4.5.4. The last time Demo worked for me was on 4.3.5. Since upgrading in September 2020, to 4.4.2, Demo has not worked.

    Do I need to down grade the clients if I take the MASTER back to 4.3.5?


  • @drewloker said in Veyon 4.5.4 VNC serveur Crash on demo mode:

    Did you downgrade the entire lab to 4.4.2?
    I still can not get Demo to work on anything from 4.4.2 through 4.5.4. The last time Demo worked for me was on 4.3.5. Since upgrading in September 2020, to 4.4.2, Demo has not worked.
    Do I need to down grade the clients if I take the MASTER back to 4.3.5?

    Hello
    I only did the test in 442 on 1 PC with the master and 1 PC with the client. and the demo mode works with the settings I made


  • @drewloker Have you tried disabling the mentioned option ("Enforce selected mode for client computers")? Currently this option causes problems with the demo mode in 4.5.x which will be fixed in the next release. However when disabling it, demo should work normally.


  • BTW Veyon 4.5.5 fixes demo mode with the "Enforce selected mode for client computers" option enabled.


  • @tobydox
    Hello thank you for coming back ... I will test this soon
    Fred


  • Hello again
    I have just made a trial installation of version 4.5.5.0 on a computer which previously had version 4.5.4.3.
    Scenario I uninstall the previous version, reboot the machine installation of version 4.5.5.0 .. installation OK, but when I run Veyon-configurator => crash with error message 87
    Capture.PNG
    I downloaded the installation sources for version 4.5.5.0 twice to be sure, always the error message.
    if I uninstall version 4.5.5.0 and reinstall version 4.5.4.3 .. no problem ...
    Capture2.PNG

    I tried to install version 4.5.5.0 over version 4.5.4.3 without uninstalling => error 87

    Obviously when switching from version 4.5.4.3 to 4.5.5.0 there is something in the configuration file that does not work .. what is weird is that obviously the configuration remains on the PC because when I reinstall the version 4.5.4.3 my LDAP and co configuration is still present even though I uninstalled it before. and delete the installation folder c : \ programfiles \ veyon
    I looked everywhere in Appdata of the user folder, that of the public user but also in ProgramData ..

    an idea ??

    Edit: After uninstalling I deleted the registry key
    Computer \ HKEY_LOCAL_MACHINE \ SOFTWARE \ Veyon because it remains => reboot => install 4.5.5.0 always the same error


  • If I install on a new machine (virtual machine) where a previous version of veyon was not installed => OK no worries ....
    Fred


  • I also did manipulation on a machine with Veyon 4.3.5 uninstallation then update to version 4.5.5 .. everything is OK ... I will do other tests on the first PC


  • OK, thank you for the feedback!


  • Good evening tobydox
    I keep trying ... even when cleaning the registry database and Appdata folder there is nothing to do .. I can install version 4.4.2.0, 4.5.4.0, 4.5.4.3 without having error message and everything is working fine.
    But if I install 4.5.5.0 or 4.5.6.0 I get the 87 load library failed error message.
    from 4.5.6 or 4.5.5.5 if I reinstall one of the 3 previous versions everything is OK even without restarting the computer ...

    Do you have an idea for me ?? I would like not to need to format the computer because I have a lot of big software for which it takes a few hours of installation ...
    Fred